Jump to content

Mi NAS casero se cuelga :(


Publicaciones recomendadas

Hola chicos... Tengo un problema :( ..

 

Mi NAS casero que tan bien funcionaba, se cuelga cada pocas horas.. lleva casi 3 años 24/7 currando como un campeón... pero no se que le ha pasado que ahora falla...

 

He mirado el registro de inicio y esto es lo mas relevante que sale:  

 

SjbhcJI.png 

 

tWf5K60.png 

 

hF48zzL.png 

 

 

Se me estará fastidiando el pendrive que contiene el sistema operativo UNRAID???  o es otra cosa...

 

Fallo de hardware no creo que sea, pues como el sistema esta en un disco USB, hace unos dias desconecte todo y lo use como un PC normal con windows 11 e incluso le aplique overclock y el hardware es estable 100%... Como NAS lo uso todo de stock incluso sin perfil XMP por asegurar estabilidad 100%, pero ni con esas, se cuelga siempre el solo, aunque lo deje sin carga..

 

Algún experto por aquí que entienda el Log y me ilumine???

 

Muchas gracias

 

Enlace al comentario
Compartir en otros sitios web

Tiene pinta no, esta arrojando en el Log varias veces que el USB se ha reconectado. Si tienes una distro en el Pendrive, y este esta fallando, pues de ahí te viene todos los problemas. 

Todo lo que se ve en el LOG es intentar leer sectores que no esta, entiendo por que el USB no "lo tiene". Puede que este empezando a fallar, si es un 24/7 leyendo de un Pen constantemente, estos tienen una vida mucho menor que los SSD/NVME. Sácalo, clonas Pendrive, y pruebas. Si hace lo mismo, entonces puede ser problema de los USB físicos. 

Enlace al comentario
Compartir en otros sitios web

SjbhcJI.png 

  • PROBLEMA: Errores ACPI de la BIOS
  • SOLUCIÓN: Actualizar BIOS o actualizar drivers

 

tWf5K60.png 

 

  • PROBLEMA: Errores SATA
  • SOLUCIÓN: Revisa cables/puertos SATA y comprueba el SMART de los discos duros

 

El primero lo puedes arreglar actualizando la BIOS (última opción) y el sistema,para el segundo te recomiendo revisar los cables,darle un limpiado a los puertos SATA y comprobar los discos duros 😉👍

Editado por FandelRJ45
Enlace al comentario
Compartir en otros sitios web

A mi me da la impresion que el problema es de placa, pero por supuesto que lo primero que haria, por facil, es guardar la configuracion del NAS si se puede y regrabar el sistema en otro pen para ver el problema.

 

Y lueo seguir los pasos de @FandelRJ45 pero vamos que para mi que es la controladora SATA, pero primero hay que comprobar discos y cables

Enlace al comentario
Compartir en otros sitios web

Publicado (editado)

Muchisimas gracias por las respuestas chicos :dios: ....

 

Acabo de llegar a casa me he conectado al NAS, y como lo deje sin hacer nada, pues sigue operativo, que cuando se cuelga es cuando curra.. porque lo uso para grabar 24/7 camaras de vigilancia lo cual hace que tenga un uso de entre el 50-60% de continuo... 

 

Lo que he obviado ayer al poner el post, porque no me acordaba, es que cuando lo probe en windows, dos puertos USB del panel tarsero están muertos, no funcionaban..

 

El equipo es viejo, es una placa MSI 170 y un i3 6100 y 16 gigas de ram.. probablemente la placa ya no lo quede mucho :( ... pero ahora no puedo vivir sin ese cacharro,  aparte del docker de CCTV, tiene también Pi-Hole y NetbootXYZ, que me proporciona arranque por red a mis otros cacharros, y Deluge para torrent, aparte de almacenamiento de peliculas y archivos...

 

Tendré que probar los discos, pero me da a mi que algo raro le ha pasado porque han empezado a salir discos defectuosos de golpe mirad:

 

HbkgQ0W.png 

 

y esto es el error que sale en el smart:

 

O6hOR6L.png 

 

5t4J411.png 

 

vSoeAPr.png 

 

 

Además, tenia varias imagenes iso de juegos y las ha corrompido :blink: y esas están el el array de 12 discos los cuales los marca como buen estado pero ya no se instalan, al querer instalar dice que esta corrupta la imagen.... que desastre jajaj, menos mal que no tiene nada importante de verdad..

 

Voy a probar con otro pendirve mañana a ver si es por eso...

 

EDITO: Que se me olvido decir que la placa tiene la ultima bios que existe para ella, asi que los errores ACPI no va ser posible solucionarlos xD

 

Un saludoteee :) 

 

 

 

 

 

Añado algo mas, que he vuelto a mirar ahora el Log del sistema y hoy a mediodia parece que han salido mas rojos xD

 

RO3pX7p.png

 

Se va autodestruir jajajjaa

 

 

Actualizo...

 

He probado con otro pendrive y en otro puerto USB,  pues hay alguno de la placa que ya no funciona :(  ...

 

Esto es lo que saca el Log y es una imagen de unraid nueva y pendrive nuevo.... así que mucho me temo que la placa o procesador no van finos

 

zMl84d5.png  

 

************************

 

PKlW83G.png  

 

**********************************

 

V0vcA0r.png 

 

WQ4F8AR.png 

 

********************************

 

iFIBaS2.png  

 

****************************

 

pKC1t5T.png 

 

veis algo muy mal por ahi??? 

 

Muchas gracias 

 

Un saludo

 

Editado por PoMpIs
Enlace al comentario
Compartir en otros sitios web

En 5/1/2023 a las 21:15, PoMpIs dijo:

Añado algo mas, que he vuelto a mirar ahora el Log del sistema y hoy a mediodia parece que han salido mas rojos xD

 

veis algo muy mal por ahi??? 

 

Muchas gracias 

 

Un saludo

 

RO3pX7p.png

 

  • Errores SATAs (parece que al disco duro Toshiba le cuesta arrancar y cuando conecta da problemas,además esta duplicado en el pool de discos BTRFS)

 

zMl84d5.png  

 

  • Ni idea pero algo relacionado con el arranque de ACPI en el kernel

 

PKlW83G.png  

 

  • Errores ACPI de la BIOS 

 

WQ4F8AR.png 

 

  • Errores SATAs (un disco duro esta muriendo)

 

iFIBaS2.png  

 

  • Problemas de escritura en la RAM (pásale un par de veces el memtest,tienes la opción en el menú de arranque)

 

Enlace al comentario
Compartir en otros sitios web

@FandelRJ45 

 

Sip, tiene un módulo de ram chungo, ya lo descubrí hace unos días :(  

 

Y el disco si, hay ocasiones que al reiniciar hay veces que aparece doble.... estaba muy "roto" ...  

 

De todos modos ya necesito mas gigas de ram, con los 16 no llega bien y cuando se llena apaga dockers... :facepalm2: 

 

Esto son daños colaterales de aprovechar hardware viejo.. todos los discos que tiene son sacados de portatiles, son todos de 2.5 pulgadas, y por encima viejos y estando en portatiles seguro que en su primera vida han llevado golpes y tampoco están preparados para 24/7 y van cascando, pero bueno, muchos ya han aguantado casi 3 años 24/7 y no me costaron nada, asi que estan desquitados xD ...  

 

Muchas gracias por la ayuda :dios:

Enlace al comentario
Compartir en otros sitios web

hace 12 horas, PoMpIs dijo:

@FandelRJ45 

 

Sip, tiene un módulo de ram chungo, ya lo descubrí hace unos días :(  

 

Y el disco si, hay ocasiones que al reiniciar hay veces que aparece doble.... estaba muy "roto" ...  

 

De todos modos ya necesito mas gigas de ram, con los 16 no llega bien y cuando se llena apaga dockers... :facepalm2: 

 

Esto son daños colaterales de aprovechar hardware viejo.. todos los discos que tiene son sacados de portatiles, son todos de 2.5 pulgadas, y por encima viejos y estando en portatiles seguro que en su primera vida han llevado golpes y tampoco están preparados para 24/7 y van cascando, pero bueno, muchos ya han aguantado casi 3 años 24/7 y no me costaron nada, asi que estan desquitados xD ...  

 

Muchas gracias por la ayuda :dios:

Yo tengo una Asrock Q1900-itx con 16 gigas en el miniNAS y 0 problemas:

  • Sistema (Debian + OpenMediaVault) en un pendrive de 64Gb
  • Docker + cache en un disco duro SSD de 512Gb
  • Docker con 11 servicios:Portainer,Heimdall,Traefik,PiHole,Seafile,Jackett,Transmission,Radarr,Sonarr,Lidarr,Jellyfin (más algunos que enciendo aleatoriamente)
  • Almacenamiento en RAID1 con 2 discos duros WD Red (4Tb+4Tb) + Disco duro externo de 4Tb como backup

Disco duros comprados de primera mano para aprovechar la garantía (5 años) de WD 😉

Enlace al comentario
Compartir en otros sitios web

Una memoria mal te puede jorobar todo el sistema, y en este caso dado que es un sistema orientado a almacenamiento pues todo: raid, sistema de archivos... todo.

 

Me recuerda a los muy viejos tiempos y cuando algunos southbridge llevaban fatal el OC, empezaban a escribir mal en los discos, pero muy poco a poco, y el sistema de archivos se iba degradando tambien poco a poco, cuando te querias dar cuenta tenias un monton de informacion irrecuperable.

Enlace al comentario
Compartir en otros sitios web

Publicado (editado)
hace 4 horas, FandelRJ45 dijo:

Yo tengo una Asrock Q1900-itx con 16 gigas en el miniNAS y 0 problemas:

  • Sistema (Debian + OpenMediaVault) en un pendrive de 64Gb
  • Docker + cache en un disco duro SSD de 512Gb
  • Docker con 11 servicios:Portainer,Heimdall,Traefik,PiHole,Seafile,Jackett,Transmission,Radarr,Sonarr,Lidarr,Jellyfin (más algunos que enciendo aleatoriamente)
  • Almacenamiento en RAID1 con 2 discos duros WD Red (4Tb+4Tb) + Disco duro externo de 4Tb como backup

Disco duros comprados de primera mano para aprovechar la garantía (5 años) de WD 😉

 

Y ese pequeña CPU puede bien con todo eso al mismo tiempo?? ... 

 

A mi lo que mas me consume es Zoneminder... eso traga ram a lo loco, en ese ordenador con 16 gigas de ram solo puedo tener ese docker mas Deluge y Pi-hole, ya tambien por la CPU que si empiezan en casa a acceder a las pelis la CPU se pone al rojo y acaba grabando a saltos y se ralentiza todo xD  ...

 

Por eso mismo ( que yo soy mucho de reciclar cacharros viejos que no compensa venderlos ) .... 

 

He empezado ayer a empaparme de OMV en un portatil lenovo con un i5 3320m y 8gb de ram :) 

 

DUgneLP.png 

 

Total ese portátil lo tenia tirado en casa sin uso ninguno, y como se le pueden poner dos discos duros e instalar OMV en un pendrive. pues estoy a ver si aprendo algo y el portatil da para manejar el Pi-hole, Deluge, JDownloader y Nextcloud y aparte que el otro haga un backup automatico en OMV...

 

Con dos discos de 4tb en el pórtatil me apaño perfectamente....

 

Pero estoy bien jodido, porque se me hace mucho mas difícil que UNRAID y llevo un lio de la leche ( pero es gratis ), llevo pocas horas trasteando pero aun no he sido capaz de instalar Deluge :facepalm2: ... tengo las OMV-extras, Docker y Portainer instalado, ( yacht no se ni lo que es, pero no se instala da un error de DNS ), pero nada mas.. lo que si he logrado instalar ha sido Zoneminder pero ni se acceder al docker ni si esta arrancado ni nada.... poco a poco lo lograré xD ...

 

Saludos 

 

 

hace 3 horas, broderick77 dijo:

Una memoria mal te puede jorobar todo el sistema, y en este caso dado que es un sistema orientado a almacenamiento pues todo: raid, sistema de archivos... todo.

 

Me recuerda a los muy viejos tiempos y cuando algunos southbridge llevaban fatal el OC, empezaban a escribir mal en los discos, pero muy poco a poco, y el sistema de archivos se iba degradando tambien poco a poco, cuando te querias dar cuenta tenias un monton de informacion irrecuperable.

 

Pues si, todas la imagenes iso se han ido a la puta, no se ha salvado ni una xD ... las pelis y los archivos pequeños no ha corrompido ninguno... los backups de steam si que han petado también... 

 

Saludos 

 

 

Editado por PoMpIs
Enlace al comentario
Compartir en otros sitios web

Hace como un año Linus Torvalds llamo literalmente a los fabricantes en general y a Intel en particular "motherfuckers" por no implementar ECC en todas las memorias y procesadores (no solo los servidores) y venia a decir que buena parte de los fallos de sistema venian dados por errores en la memoria, que los fabricantes (tambien literalmente) nos estan vendiendo mierda.

 

Yo he de decir, que llevo dos años trabajando con una WS con memoria ECC, y no se porque pero me da la impresion de que todo va mas fino, y mi sistema es de hace varias generaciones. Desde hace muchos años cada vez que he trabajado con una WS de calidad, ya sea Dell o HP he notado no una mejora en el rendimiento, sino un sistema mas estable, mas suave todo, ya fuera con Opterones o con Xeon, y es que los componenetes de servidor se nota, y claro, trabajar con memorias ECC supongo que tambien.

Enlace al comentario
Compartir en otros sitios web

hace 3 horas, PoMpIs dijo:

 

Y ese pequeña CPU puede bien con todo eso al mismo tiempo?? ... 

 

A mi lo que mas me consume es Zoneminder... eso traga ram a lo loco, en ese ordenador con 16 gigas de ram solo puedo tener ese docker mas Deluge y Pi-hole, ya tambien por la CPU que si empiezan en casa a acceder a las pelis la CPU se pone al rojo y acaba grabando a saltos y se ralentiza todo xD  ...

 

Por eso mismo ( que yo soy mucho de reciclar cacharros viejos que no compensa venderlos ) .... 

 

He empezado ayer a empaparme de OMV en un portatil lenovo con un i5 3320m y 8gb de ram :) 

 

Casi todo al mismo tiempo y 2 usuarios máximos viendo peli/series por streaming:

  • Portainer > siempre funcionando
  • Heimdall  > siempre funcionando
  • Traefik  > siempre funcionando
  • PiHole  > siempre funcionando
  • Seafile  > siempre funcionando
  • Jackett  > siempre funcionando
  • Transmission  > solo cuando hay algún torrent descargando
  • Radarr > solo cuando buscas películas y descargas
  • Sonarr > solo cuando buscas series y descargas
  • Lidarr > siempre funcionando (escuchar musica no consume casi nada)
  • Jellyfin > siempre funcionando (consume cuando reproduce películas/series o actualiza la base de datos)

He mirado Zoneminder y por lo que veo es famoso por comerse la memoria

MdUQHON.png

 

Idem con los cacharros viejos,son mi laboratorio para probar cosas nuevas 🤭

Enlace al comentario
Compartir en otros sitios web

hace 16 minutos, FandelRJ45 dijo:

Casi todo al mismo tiempo y 2 usuarios máximos viendo peli/series por streaming:

  • Portainer > siempre funcionando
  • Heimdall  > siempre funcionando
  • Traefik  > siempre funcionando
  • PiHole  > siempre funcionando
  • Seafile  > siempre funcionando
  • Jackett  > siempre funcionando
  • Transmission  > solo cuando hay algún torrent descargando
  • Radarr > solo cuando buscas películas y descargas
  • Sonarr > solo cuando buscas series y descargas
  • Lidarr > siempre funcionando (escuchar musica no consume casi nada)
  • Jellyfin > siempre funcionando (consume cuando reproduce películas/series o actualiza la base de datos)

He mirado Zoneminder y por lo que veo es famoso por comerse la memoria

Spoiler

MdUQHON.png

 

 

 

Idem con los cacharros viejos,son mi laboratorio para probar cosas nuevas 🤭

 

xD .... es que no veas como traga el Zoneminder..... tengo el i3 que ahora mismo no puede mas mira:

 

xv6j1o8.png

 

LLeva así ya un buen rato, porque esta haciendo un backup también, pero no hay nadie accediendo a el ahora mismo, solo tiene Pi-hole, Zoneminder y hacer backup incremental.... si arranco mas docker ya esta siempre al 80-90% 24/7 el cacharro y la memoria se va al tope xD ... a ver si pillo mas gigas, que estos son unos viejos que tenia por aquí en un cajón.... no hago mas que aprovechar cosas viejas.

 

A veces es un poco caca, porque si te pilla viendo una peli a veces se traba la pelicula....  pero va currar hasta que no pueda mas... a ver si el portátil le ayuda un poco, que parece que el i3 del Lenovo puede con 3 cámaras mas el torrent y aun queda fuelle para backup :banana:... este portátil es indestructible jajaja

 

 

 

 

Enlace al comentario
Compartir en otros sitios web

hace 10 horas, broderick77 dijo:

Hace como un año Linus Torvalds llamo literalmente a los fabricantes en general y a Intel en particular "motherfuckers" por no implementar ECC en todas las memorias y procesadores (no solo los servidores) y venia a decir que buena parte de los fallos de sistema venian dados por errores en la memoria, que los fabricantes (tambien literalmente) nos estan vendiendo mierda.

 

Yo he de decir, que llevo dos años trabajando con una WS con memoria ECC, y no se porque pero me da la impresion de que todo va mas fino, y mi sistema es de hace varias generaciones. Desde hace muchos años cada vez que he trabajado con una WS de calidad, ya sea Dell o HP he notado no una mejora en el rendimiento, sino un sistema mas estable, mas suave todo, ya fuera con Opterones o con Xeon, y es que los componenetes de servidor se nota, y claro, trabajar con memorias ECC supongo que tambien.

 

DDR5 creo que incluye ya ECC, pero no creo que solucione esos problemas ya que al fin y al cabo hasta los servidores con ese tipo de ram fallan con el tiempo, aunque al menos previenes de errores del sistema.

Enlace al comentario
Compartir en otros sitios web

Por favor conéctate para comentar

Podrás dejar un comentario después de iniciar sesión



Conectar ahora
 Compartir

×
×
  • Crear nuevo...