Ir a contenido

Linux Mint tarda mucho en arrancar


  • Por favor inicia una sesión para responder
10 respuestas en este tema
  • Oddie_
  • Provincia:Valencia


Buenas...

 

Este problema no es mío. A mí afortunadamente me está yendo muy bien en los equipos donde lo voy instalando.

 

La historia es que he convencido a un amigo para que se ponga Mint 18.1 XFCE en su portátil (un Packard Bell Etna-GM, Core2-Duo a 2Ghz, 4GB, SSD 240GB). Más bien se convenció él solo, lo vio instalado en uno de mis portátiles y le gustó tanto que ya no quería tener Windows 10 en su ordenador, así que comprobé que el hardware era compatible, arranqué con un pen y todo iba perfecto, con lo cual me puse al lío.

Le hice un borrado de particiones, creé la partición raíz, la /home y la swap y completé la instalación. Todo sin problemas. 

 

Ahora resulta que, cuando arranca, sale el POST de la BIOS, borra pantalla y enseguida debería aparecer el logo de Linux Mint, pero se queda parado como 3 minutos con la pantalla negra y después ya sí continúa el arranque normal y funciona todo aparentemente bien.

Esto pasa siempre, da igual que arranques en frío como que reinicies, y da igual también la opción de arranque que elijas. Le instalé Cinnamon por encima de XFCE y al cambiar el escritorio por defecto sigue con el mismo problema, los 3 minutos de espera no se los quita nadie.

 

 

A mí sólo se me ocurre que pueda tener algo que ver el hecho de no haber creado una partición /boot, pero me extraña porque yo no la he creado en ninguno de mis ordenadores y arrancan todos bien.

 

¿Alguna idea?


Escrito 28 julio 2017 - 20:18        Editado por Oddie_, 28 julio 2017 - 20:23.




  • Tew
  • Provincia:Malaga


Echa un ojo a este hilo: https://forums.linux...ic.php?t=225743 (mira la solución final, y a las malas revisa el proceso paso a paso). En resumen parece que era un problema con el UUID de alguna partición en fstab.

Sino, en Google por "mint slow boot" hay un montón de resultados :D

  • Valorado por Oddie_

Escrito 28 julio 2017 - 21:29        Editado por Tew, 28 julio 2017 - 21:34.


  • Oddie_
  • Provincia:Valencia


Echa un ojo a este hilo: https://forums.linux...ic.php?t=225743 (mira la solución final, y a las malas revisa el proceso paso a paso). En resumen parece que era un problema con el UUID de alguna partición en fstab.

Sino, en Google por "mint slow boot" hay un montón de resultados :D

 

Buff, madre mía... Te juro que he buscado en el foro de Mint antes de preguntar aquí. Supongo que estoy tan verde que todavía no sé ni buscar bien  :oops:

 

Vale, he hecho una comprobación en mi portátil para ver que las UUID del blkid y del GParted coinciden. En mi caso están bien y ya tengo claro cómo encontrar "la avería" en el portátil de mi amigo. Lo que no me ha quedado claro leyendo ese hilo es si tiene solución aparte de desactivar la swap.

 

Hombre, tiene 4GB de RAM y el disco es SSD, así que por un lado no necesitará imperiosamente la swap y por otro lado ni siquiera es conveniente que la tenga por ser SSD, pero... ¿se puede arreglar el asunto? Es por si acaso se me da en algunos de mis ordenadores, ya que pienso instalarlo en equipos con menos de 1GB de RAM y me vendría bien saber cómo hacerlo.

 

¿Editando /etc/fstab y poniendo los UUID del blkid se solucionará?


Escrito 28 julio 2017 - 22:40        Editado por Oddie_, 28 julio 2017 - 22:45.


  • Tew
  • Provincia:Malaga


Si el problema es ese, claro.


Escrito 29 julio 2017 - 14:20


  • Oddie_
  • Provincia:Valencia


Pues no era ése el problema, los UUID coincidían. Seguiré buscando.

 

Si a alguien se le ocurre algo, soy todo ojos! 


Escrito 31 julio 2017 - 20:59


  • Tew
  • Provincia:Malaga


¿Has probado a buscar la cadena que te comenté en Google? Hay muchos resultados, y muchas causas.

 

Podría ser "ntp". Aquí como deshabilitarlo/habilitarlo:
 

 

Sometimes the Network Time Protocol (NTP) is the culprit. If it's ntp.service that's eating all that time, you might try this:

Type (copy/paste to avoid errors):

sudo systemctl disable ntp

Press Enter. Type your password when required; this remains entirely invisible, not even dots will show, this is normal.

The price you pay for disabling NTP, by the way, is that your system time is no longer being synchronized with NTP servers. This is usually only a minor inconvenience.

Do you want to undo this? That's easy:

sudo systemctl enable ntp



O a causa del hardware. Aquí como buscar indicios:

 

 

18. On some hardware, booting lasts extremely long. You can try to find the cause of a slow boot as follows:

Launch a terminal window.

Copy/paste the following line into the terminal, to avoid errors:

systemd-analyze blame

Press Enter.

 

Sacado de aquí: https://sites.google...ipsproject/bugs (lectura interesante, al igual que otros artículos suyos sobre como optimizar dichos sistemas :bien: )

  • Valorado por Oddie_

Escrito 31 julio 2017 - 21:30


  • cpt.charlie
  • Provincia:Cantabria


Lo mismo ha sido un problema causado por una actualización (a mí me pasó justo esto con una fedora, y lo mismo que vino se largó)

 

Saludos.


Escrito 31 julio 2017 - 22:39

YO TAMBIÉN SOY EDUCADO, Y DEVUELVO LOS MENSAJES PRIVADOS


  • Oddie_
  • Provincia:Valencia


Lo mismo ha sido un problema causado por una actualización (a mí me pasó justo esto con una fedora, y lo mismo que vino se largó)

 

No es el caso, está recién instalado y tarda 3 minutos desde el primer reinicio, incluso antes de actualizar.

 

La semana pasada le instalé el 18.1 64 bits y esta semana lo he vuelto a formatear y he puesto un Windows 7 + Linux Mint 18.1 32 bits. El problema persiste, pero sólo cuando arranca Linux, con Windows arranca bien.

 

Noto que el ordenador es especialmente lento en la BIOS, los menús van como con 1 segundo de retardo, pero no entiendo que sólo se ralentice el arranque con Linux.

 

Acaba de probar con lo que ha puesto Tew en el último mensaje y no hace efecto. Con 'systemd-analyze blame' todos los procesos tardan milisegundos, excepto dev-sda4.device que tarda 1'4 segundos (se me hace raro que tarde tanto siendo SSD, pero aun así no veo los 3 minutos por ningún sitio).


Escrito 31 julio 2017 - 23:31


  • Ronon
  • Provincia:Palencia


Igual es una chorrada... ¿pero has mirado que Sata esté en modo Ahci en la BIOS? O si no, ¿no hay algún archivo que te muestre un registro del arranque? O un comando como:

tail /var/log/dmesg: mostrar eventos inherentes al proceso de carga del kernel.

tail /var/log/messages: mostrar los eventos del sistema.

Un saludo.

Escrito 14 agosto 2017 - 09:48

PLATAFORMA........
"" YO TAMBIEN SOY EDUCADO, Y DEVUELVO LOS MENSAJES PRIVADOS ""
......únete y pasalo


  • pepitofernando
  • Provincia:Madrid


Arrancas con uefi o con legacy?

Prueba a arrancar con legacy en caso de poder elegir...

Escrito 14 agosto 2017 - 10:15

Un saludo a tod@s

  • el_angel_caido
  • Provincia:Asturias


Hola.

 

La existencia o no de /boot de forma independiente no debería influir.

 

Que sea un SSD tampoco si hablamos de un kernel más o menos reciente, pues creo que a partir de un cierto kernel ya no hay que hacer nada adicional con los SSD (ésto lo pongo de "oídas", nunca he usado un SSD).

 

Lo que deberías mirar es la secuencia de arranque a ver si ves dónde se para, y como me imagino que usarás la configuración de Grub2 por defecto, ésta estará con la opciones para que no muestre dicha secuencia de arranque y sí muestre el splash o el plymouth (vamos, la animación de carga). Para cambiar ésto sin tocar la configuración de Grub2 entra en la opción avanzada del menú del Grub2 (no se cómo lo llamará en Linux Mint) y borra quiet, silent y splash; debería iniciar con toda la información de arranque, y mostrar todos los eventos de carga, así dónde se para y, puede, porqué.

 

Otra manera es una vez iniciado, como indica Ronon, mirar el dmesg (tiene un comando propio, no hace falta ir a /var/log). También se pueden mirar otros archivos de log, como el messages y el boot.log. El sistema de logs de systemd no me gusta demasiado, pero siempre se puede "forzar" a usar un sistema de logs más clásico, como instalar rsyslog.

 

Una ralentización durante el arranque puede venir de muchas cosas, de que la tarjeta de red no se levante correctamente y no pille bien la configuración de red, de que haya un pincho USB que por lo que sea el sistema intente montarlo durante el arranque, que el /etc/fstab no esté bien definido e intente montar algo que no existe o está mal configurado, que algún servicio se quede en espera de algo porque esperaba algo, etc., etc.

 

El inicio rápido de WIndows (desde Windows 7) también puede producir ralentización del arranque, entre otras cosas porque el sistema Linux no es capaz de manejar las particiones NTFS "sin cerrar" de ese sistema de apagado de Windows, incluso, si no recuerdo mal, con Windows 10, directamente para el arranque de Linux; sobre todo si la partición NTFS en cuestión está definida en fstab para ser montada durante el arranque (con ntfs-3g).

Y lo mismo con el Fast Boot de la UEFI/BIOS.

 

Pero entre ver el proceso de arranque y los logs deberíamos poder ver algo raro.

 

Suerte y un saludo. 8-)


Escrito 14 agosto 2017 - 10:50



0 usuario(s) estan leyendo este tema

0 miembros, 0 invitados, 0 usuarios anónimos