Ir a contenido

Harto de la velocidad de transferencia de datos a un usb


  • Por favor inicia una sesión para responder
7 respuestas en este tema
  • javivi-2007
  • Provincia:Malaga


Pues aqui estamos...

Con el problemilla famoso de lentitud al copiar del disco duro al usb.

Soy un admirador de ubuntu y hace mas de 3 años que lo uso pero hay algunas cosas que no consigo comprender....

Intento copiar un archivo de 4,7 gb del disco duro al usb.

Empieza a 130 mb/s pero va ralentizandose paulatinamente y cuando pasa de 1,4 gb se para cada vez mas hasta llegar a menos de 1 mb/s y bajando.....

He probado cambiando de puerto (delanteros y traseros), de usb (todos usb2 pero distintas capacidades y marcas), distintos formatos (fat, nfts...) pero sigue igual.

Lo mas triste es que no es un problema nuevo ya que en internet se ven miles de personas que se quejan de lo mismo desde antes del 2008 y hoy en dia con el ultimo ubuntu sigue pasando lo mismo. Y por lo que leo tambien pasa en otras versiones de linux. Puedo comprender que haya algun error en alguna version y que se tarde un tiempo prudencial en solucionarlo pero mas de 9 años me parece excesivo.

¿no lo va a solucionar nadie? ¿a nadie le importa?

Ya adelanto que la solucion no es quitar usb legacy de la bios ni editar nosequefichero para añadirle nosecual opcion...

Esto es una verguenza y con cosas como esta tendremos que seguir aguantando las risas de los colegas cuando les dices que usas ubuntu.

En fin, estoy indignado porque no parece tener solucion. Por lo visto nos tenemos que fastidiar y punto porque parece ser que nadie va a arreglarlo. A ver si alguien mas experto sabe de alguna solucion porque es desesperante esperar mas de 2 horas para copiar tres archivos de 4,5 gb (menos de 15 gb en total).

En el mismo equipo y con los mismos dispositivos con windows tarda menos de 50 minutos  (un 40% de lo que tarda ubuntu) y va a una velocidad constante de 5 mb/s.

Lo curioso es que en ubuntu hasta 1,4 gb va de escandalo consiguiendo velocidades de hasta 130 mb/seg (cuando el dispositivo usb tiene solo 5 mb de escritura). No se como lo hace, si usando cache del dispositivo, cache del sistema, swap.... El caso es que parece que una vez que se llena esa cache o lo que sea comienza a bajar y lo mas curioso y lo decepcionante es que en vez de bajar a los 5 mb/s del dispositivo sigue bajando hasta poco mas de 700kb/s. Y asi va paradisimo.


Escrito 28 abril 2017 - 18:14        Editado por javivi-2007, 29 abril 2017 - 11:32.


  • Tew
  • Provincia:Malaga


Y si sigues indagando verás que lo mismo ocurre en Windows (a 4.x mb/s me termina copiando peliculas).

 

Si quieres más velocidad tendras que cambiarte a USB 3 (tanto los puertos como el dispositivo).

  • Valorado por Maxmalkav

Escrito 28 abril 2017 - 18:31


  • Dyno
  • Provincia:Pontevedra


Yo también tenía esos problemas. Fue cuando cambié de memorias a otras de alta velocidad de lectura / escritura en USB 3.0 y se acabó el problema.

 

Además también tiene que ver si grabas en un dispositivo formateado en fat, ntfs, ext2,3,4, etc...

En ntfs no va a ir bien, ya que ntfs no es un sistema nativo de linux y hace falta otro programa para poder escribir en el, con el consecuente gasto de RAM y CPU.

 

Por último, en el kernel 4.10, una de las mejoras que trae es la escritura en dispositivos USB.

 

Saludos.

  • Valorado por broderick77

Escrito 28 abril 2017 - 20:01


  • andye
  • H2M SILVER
  • Provincia:Ciudad Real


Pues que quieres que te diga, en usb 3.0 con un Pen toshiba normalito me vs de vicio. Y hacia un HDD toshiba también.
  • Valorado por darkhackjl

Escrito 28 abril 2017 - 22:25


  • Alentines
  • Provincia:A Coruña


Yo con usb2.0 acabé desesperado, menos mal que ahora hago uno uso residual de pendrives que me quedan con esa conexión.


Escrito 29 abril 2017 - 11:03        Editado por Alentines, 29 abril 2017 - 20:08.


  • Tew
  • Provincia:Malaga


Acabo de copiar 9.8Gb a un pendrive USB 2.0 desde un puerto USB 2.0 en Ubuntu 14.04. Con una tasa de transferencia de 4.8MB/s.

 

Básicamente idéntica que la tasa lograda en Windows 7...


Escrito 29 abril 2017 - 19:30        Editado por Tew, 29 abril 2017 - 19:31.


  • ismarub
  • Provincia:Vizcaya


Eso no es nuevo. Muchos S.O usan un buffer antes de copiar los archivos y luego si el dispositivo es lento se atasca. Como el pendrive sea lentorro suele pasar eso. Windows 10 al menos no me ha pasado eso. Si usáis windows 7 os recomiendo teracopy. Es un programa para mover, copiar y cortar archivos como alternativa al de windows. Con este programa va todo lineal. Si el pendrive da 6MB/S de escritura, así va todo el rato, sin cuellos de botella y sin saturaciones.


Escrito 29 abril 2017 - 19:58        Editado por ismarub, 29 abril 2017 - 19:59.


  • Yorus
  • Provincia:Madrid


Esos problemas me los encontré con muchos pendrive. A veces parecía que había acabado pero si el pendrive tenía led se podía ver que seguía trabajando y además no podía expulsarlo con seguridad. Esto me pasaba sobre todo con pendrive malos y con un Lexar USB 3.0. Harto me compre un Sandisk Extreme y cero problemas. Ayer hice copias grandes con un disco USB 2.0 y tampoco tuve problemas (Mint 18.1 mate e un Intel NUC Slylake).

Enviado desde mi Aquaris_M4.5 mediante Tapatalk

Escrito 29 abril 2017 - 20:21

Plataforma ... "Yo también soy educado y devuelvo los mensajes privados" ... Únete a la causa


0 usuario(s) estan leyendo este tema

0 miembros, 0 invitados, 0 usuarios anónimos